FreeBSD : plans -- multiple vulnerabilities (1709084d-4d21-11db-b48d-00508d6a62df)

High Nessus Plugin ID 22451


The remote FreeBSD host is missing a security-related update.


Secunia reports :

A vulnerability has been reported in Plans, which can be exploited by malicious people to conduct SQL injection attacks.

Input passed to the 'evt_id' parameter in 'plans.cgi' isn't properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

Successful exploitation requires that SQL database support has been enabled in '' (the default setting is flat files).

Some vulnerabilities have been reported in Plans, which can be exploited by malicious people to conduct cross-site scripting attacks or gain knowledge of sensitive information.

Input passed to various unspecified parameters is not properly sanitised before being returned to users. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of a vulnerable site.

An unspecified error can be exploited to gain knowledge of the MySQL password.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 22451

File Name: freebsd_pkg_1709084d4d2111dbb48d00508d6a62df.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2006/09/27

Modified: 2016/12/08

Dependencies: 12634

Risk Information

Risk Factor: High

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:plans, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2006/09/26

Vulnerability Publication Date: 2005/04/28

Reference Information

BID: 14069

Secunia: 15167, 15854