FreeBSD : x11vnc -- authentication bypass vulnerability (9dda3ff1-2b02-11db-a6e2-000e0c2e438a)

High Nessus Plugin ID 22212


The remote FreeBSD host is missing a security-related update.


Ludwig Nussel reports that x11vnc is vulnerable to an authentication bypass vulnerability. The vulnerability is caused by an error in auth.c. This could allow a remote attacker to gain unauthorized and unauthenticated access to the system.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 22212

File Name: freebsd_pkg_9dda3ff12b0211dba6e2000e0c2e438a.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2006/08/14

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:x11vnc, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/08/13

Vulnerability Publication Date: 2006/08/08

Reference Information

CVE: CVE-2006-2450

BID: 18977