Horde < 3.0.11 / 3.1.2 Multiple Script XSS

Medium Nessus Plugin ID 22004

Synopsis

The remote web server contains a PHP script that is affected by multiple cross-site scripting vulnerabilities.

Description

The version of Horde installed on the remote host fails to validate input to the 'url' parameter of the 'services/go.php' script before using it in dynamically-generated content. An unauthenticated attacker may be able to leverage this issue to inject arbitrary HTML and script code into a user's browser.

In addition, similar cross-site scripting issues reportedly exist with the 'module' parameter of the 'services/help/index.php' script and the 'name' parameter of the 'services/problem.php' script.

Solution

Upgrade to Horde 3.0.11 / 3.1.2 or later.

See Also

https://seclists.org/fulldisclosure/2006/Jul/91

https://lists.horde.org/archives/announce/2006/000287.html

https://lists.horde.org/archives/announce/2006/000288.html

Plugin Details

Severity: Medium

ID: 22004

File Name: horde_url_xss.nasl

Version: 1.24

Type: remote

Published: 2006/07/05

Updated: 2018/11/15

Dependencies: 15604, 10815

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:horde:horde_application_framework

Required KB Items: www/horde

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: false

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2006/07/05

Reference Information

CVE: CVE-2006-3548, CVE-2006-3549

BID: 18845

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990