FreeBSD : horde -- multiple parameter XSS vulnerabilities (09429f7c-fd6e-11da-b1cd-0050bf27ba24)

Medium Nessus Plugin ID 21730


The remote FreeBSD host is missing one or more security-related updates.


FrSIRT advisory ADV-2006-2356 reports :

Multiple vulnerabilities have been identified in Horde Application Framework, which may be exploited by attackers to execute arbitrary scripting code. These flaws are due to input validation errors in the 'test.php' and 'templates/problem/' scripts that do not validate the 'url', 'name', 'email', 'subject' and 'message' parameters, which could be exploited by attackers to cause arbitrary scripting code to be executed by the user's browser in the security context of an affected Website.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 21730

File Name: freebsd_pkg_09429f7cfd6e11dab1cd0050bf27ba24.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/06/19

Modified: 2014/08/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:horde, p-cpe:/a:freebsd:freebsd:horde-php5, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2006/06/17

Vulnerability Publication Date: 2006/06/10

Reference Information

CVE: CVE-2006-2195