Mandrake Linux Security Advisory : php (MDKSA-2006:091)

Medium Nessus Plugin ID 21602


The remote Mandrake Linux host is missing one or more security updates.


An integer overflow in the wordwrap() function could allow attackers to execute arbitrary code via certain long arguments that cause a small buffer to be allocated, triggering a heap-based buffer overflow (CVE-2006-1990).

The substr_compare() function in PHP 5.x and 4.4.2 could allow attackers to cause a Denial of Service (memory access violation) via an out-of-bounds offset argument (CVE-2006-1991).

The second vulnerability only affects Mandriva Linux 2006; earlier versions shipped with older versions of PHP that do not contain the substr_compare() function.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 21602

File Name: mandrake_MDKSA-2006-091.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/05/27

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64php5_common5, p-cpe:/a:mandriva:linux:lib64php_common432, p-cpe:/a:mandriva:linux:libphp5_common5, p-cpe:/a:mandriva:linux:libphp_common432, p-cpe:/a:mandriva:linux:php-cgi, p-cpe:/a:mandriva:linux:php-cli, p-cpe:/a:mandriva:linux:php-devel, p-cpe:/a:mandriva:linux:php-fcgi, p-cpe:/a:mandriva:linux:php432-devel, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/05/24

Reference Information

CVE: CVE-2006-1990, CVE-2006-1991

MDKSA: 2006:091