CVE-2006-1991

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The substr_compare function in string.c in PHP 5.1.2 allows context-dependent attackers to cause a denial of service (memory access violation) via an out-of-bounds offset argument.

References

http://secunia.com/advisories/20052

http://secunia.com/advisories/20269

http://secunia.com/advisories/20676

http://secunia.com/advisories/21125

http://security.gentoo.org/glsa/glsa-200605-08.xml

http://securitytracker.com/id?1015979

http://www.infigo.hr/en/in_focus/advisories/INFIGO-2006-04-02

http://www.mandriva.com/security/advisories?name=MDKSA-2006:091

http://www.novell.com/linux/security/advisories/2006_31_php.html

http://www.ubuntu.com/usn/usn-320-1

http://www.vupen.com/english/advisories/2006/1500

https://exchange.xforce.ibmcloud.com/vulnerabilities/26003

Details

Source: MITRE

Published: 2006-04-24

Updated: 2017-07-20

Type: CWE-399

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:5.1.2:*:*:*:*:*:*:*

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
27897Ubuntu 5.04 / 5.10 / 6.06 LTS : php4, php5 vulnerabilities (USN-320-1)NessusUbuntu Local Security Checks
high
27389openSUSE 10 Security Update : php5 (php5-1590)NessusSuSE Local Security Checks
medium
22268PHP < 4.4.3 / 5.1.4 Multiple VulnerabilitiesNessusCGI abuses
high
22053Mandrake Linux Security Advisory : php (MDKSA-2006:122)NessusMandriva Local Security Checks
critical
21602Mandrake Linux Security Advisory : php (MDKSA-2006:091)NessusMandriva Local Security Checks
medium
21350GLSA-200605-08 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium