Slackware 10.2 / current : tetex PDF security (SSA:2006-142-01)

Medium Nessus Plugin ID 21583


The remote Slackware host is missing a security update.


New tetex packages are available for Slackware 10.2 and -current to fix a possible security issue. teTeX-3.0 incorporates some code from the xpdf program which has been shown to have various overflows that could result in program crashes or possibly the execution of arbitrary code as the teTeX user. This is especially important to consider if teTeX is being used as part of a printer filter.


Update the affected tetex and / or tetex-doc packages.

See Also

Plugin Details

Severity: Medium

ID: 21583

File Name: Slackware_SSA_2006-142-01.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2006/05/23

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:tetex, p-cpe:/a:slackware:slackware_linux:tetex-doc, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.2

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/05/22

Reference Information

CVE: CVE-2005-3193

BID: 15721

SSA: 2006-142-01