FreeBSD : acroread -- plug-in buffer overflow vulnerability (f74dc01b-0e83-11da-bc08-0001020eed82)

High Nessus Plugin ID 21540


The remote FreeBSD host is missing one or more security-related updates.


A Adobe Security Advisory reports :

The identified vulnerability is a buffer overflow within a core application plug-in, which is part of Adobe Acrobat and Adobe Reader.
If a malicious file were opened it could trigger a buffer overflow as the file is being loaded into Adobe Acrobat and Adobe Reader. A buffer overflow can cause the application to crash and increase the risk of malicious code execution.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 21540

File Name: freebsd_pkg_f74dc01b0e8311dabc080001020eed82.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2006/05/13

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:acroread, p-cpe:/a:freebsd:freebsd:acroread4, p-cpe:/a:freebsd:freebsd:acroread5, p-cpe:/a:freebsd:freebsd:acroread7, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/08/16

Vulnerability Publication Date: 2005/08/16

Reference Information

CVE: CVE-2005-2470