FreeBSD : mediawiki -- hardcoded placeholder string security bypass vulnerability (99015cf5-c4dd-11da-b2fb-000e0c2e438a)

Medium Nessus Plugin ID 21482


The remote FreeBSD host is missing a security-related update.


The mediawiki development team reports a vulnerability within the mediawiki application. The vulnerability is caused by improper checking of inline style attributes. This could result in the execution of arbitrary JavaScript code in Microsoft Internet Explorer.
It appears that other browsers are not affected by this vulnerability.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 21482

File Name: freebsd_pkg_99015cf5c4dd11dab2fb000e0c2e438a.nasl

Version: $Revision: 1.21 $

Type: local

Published: 2006/05/13

Modified: 2014/05/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:mediawiki, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/04/05

Vulnerability Publication Date: 2005/12/22

Reference Information

CVE: CVE-2005-4501

BID: 16032