FreeBSD : crossfire-server -- denial of service and remote code execution vulnerability (86cc5c6f-d2b4-11da-a672-000e0c2e438a)

Medium Nessus Plugin ID 21465


The remote FreeBSD host is missing a security-related update.


FRSIRT reports :

A vulnerability has been identified in CrossFire, which could be exploited by remote attackers to execute arbitrary commands or cause a denial of service. This flaw is due to a buffer overflow error in the 'oldsocketmode' module that fails to properly handle overly large requests, which could be exploited by a malicious client to crash or compromise a vulnerable system.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 21465

File Name: freebsd_pkg_86cc5c6fd2b411daa672000e0c2e438a.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/05/13

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:crossfire-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/04/23

Vulnerability Publication Date: 2006/02/28

Reference Information

CVE: CVE-2006-1010

BID: 16883