FreeBSD : kaffeine -- buffer overflow vulnerability (4bfcd857-c628-11da-b2fb-000e0c2e438a)

Medium Nessus Plugin ID 21426


The remote FreeBSD host is missing a security-related update.


The KDE team reports :

Kaffeine can produce a buffer overflow in http_peek() while creating HTTP request headers for fetching remote playlists, which under certain circumstances could be used to crash the application and/or execute arbitrary code.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 21426

File Name: freebsd_pkg_4bfcd857c62811dab2fb000e0c2e438a.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2006/05/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:kaffeine, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/04/07

Vulnerability Publication Date: 2006/04/04

Reference Information

CVE: CVE-2006-0051

BID: 17372