FreeBSD : nbd-server -- buffer overflow vulnerability (43770b1c-72f6-11da-8c1d-000e0c2e438a)

High Nessus Plugin ID 21420


The remote FreeBSD host is missing a security-related update.


Kurt Fitzner reports a buffer overflow vulnerability within nbd. This could potentially allow the execution of arbitrary code on the nbd server.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 21420

File Name: freebsd_pkg_43770b1c72f611da8c1d000e0c2e438a.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2006/05/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:nbd-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/12/22

Vulnerability Publication Date: 2005/12/21

Reference Information

CVE: CVE-2005-3534

DSA: 924