FreeBSD : pam_ldap -- authentication bypass vulnerability (38c76fcf-1744-11da-978e-0001020eed82)

High Nessus Plugin ID 21413


The remote FreeBSD host is missing a security-related update.


Luke Howard reports :

If a pam_ldap client authenticates against an LDAP server that returns a passwordPolicyResponse control, but omits the optional 'error' field of the PasswordPolicyResponseValue, then the LDAP authentication result will be ignored and the authentication step will always succeed.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 21413

File Name: freebsd_pkg_38c76fcf174411da978e0001020eed82.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2006/05/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:pam_ldap, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/08/27

Vulnerability Publication Date: 2005/08/22

Reference Information

CVE: CVE-2005-2641

CERT: 778916