SUSE-SA:2006:009: gpg,liby2util

High Nessus Plugin ID 20967


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2006:009 (gpg,liby2util).

With certain handcraftable signatures GPG was returning a 0 (valid signature) when used on command-line with option --verify.

This only affects GPG version 1.4.x, so it only affects SUSE Linux 9.3 and 10.0. Other SUSE Linux versions are not affected.

This could make automated checkers, like for instance the patch file verification checker of the YaST Online Update, pass malicious patch files as correct.

This is tracked by the Mitre CVE ID CVE-2006-0455.

Also, the YaST Online Update script signature verification had used a feature which was lost in gpg 1.4.x, making it possible to supply any kind of script which would be thought correct. This would also allow code execution.

Both attacks require an attacker either manipulating a YaST Online Update mirror or manipulating the network traffic between the mirror and your machine.


Plugin Details

Severity: High

ID: 20967

File Name: suse_SA_2006_009.nasl

Version: $Revision: 1.4 $

Agent: unix

Published: 2006/02/22

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list