SUSE-SA:2006:008: openssh

High Nessus Plugin ID 20923


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2006:008 (openssh).

A problem in the handling of scp in openssh could be used to execute commands on remote hosts even using a scp-only configuration.

This requires doing a remote-remote scp and a hostile server. (CVE-2006-0225)

On SUSE Linux Enterprise Server 9 the xauth pollution problem was fixed too.

The security fix changes the handling of quoting filenames which might break automated scripts using this functionality.

Please check that your automated scp scripts still work after the update.


Plugin Details

Severity: High

ID: 20923

File Name: suse_SA_2006_008.nasl

Version: $Revision: 1.4 $

Agent: unix

Published: 2006/02/15

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list