Mandrake Linux Security Advisory : wget (MDKSA-2005:183)

High Nessus Plugin ID 20430


The remote Mandrake Linux host is missing a security update.


A vulnerability in libcurl's NTLM function can overflow a stack-based buffer if given too long a user name or domain name in NTLM authentication is enabled and either a) pass a user and domain name to libcurl that together are longer than 192 bytes or b) allow (lib)curl to follow HTTP redirects and the new URL contains a URL with a user and domain name that together are longer than 192 bytes.

Wget, as of version 1.10, uses the NTLM code from libcurl and is also vulnerable to this issue.

The updated packages have been patched to address this issue.


Update the affected wget package.

See Also

Plugin Details

Severity: High

ID: 20430

File Name: mandrake_MDKSA-2005-183.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2006/01/15

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:wget, cpe:/o:mandriva:linux:2006

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/10/13

Reference Information

CVE: CVE-2005-3185

MDKSA: 2005:183