SUSE-SA:2005:065: gtk2, gdk-pixbuf

High Nessus Plugin ID 20239


The remote host is missing a vendor-supplied security patch.


The remote host is missing the patch for the advisory SUSE-SA:2005:065 (gtk2, gdk-pixbuf).

The image loading library of the gdk-pixbug/gtk2 package is vulnerable to several security-related bugs. This makes every application (mostly GNOME applications) which is linked against this library vulnerable too.

A carefully crafted XPM file can be used to execute arbitrary code while processing the image file. (CVE-2005-3186)

Additionally Ludwig Nussel from the SuSE Security-Team discovered an integer overflow bug that can be used to execute arbitrary code too (CVE-2005-2976), and an infinite loop which leads to a denial of service bug. (CVE-2005-2975)


Plugin Details

Severity: High

ID: 20239

File Name: suse_SA_2005_065.nasl

Version: $Revision: 1.5 $

Agent: unix

Published: 2005/11/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list