Fedora Core 4 : w3c-libwww-5.4.0-13.0.FC4.1 (2005-952)

Medium Nessus Plugin ID 19971


The remote Fedora Core host is missing a security update.


This update fixes libwww's handling of multipart/byteranges content and a possible stack overflow.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also


Plugin Details

Severity: Medium

ID: 19971

File Name: fedora_2005-952.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2005/10/11

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:w3c-libwww, p-cpe:/a:fedoraproject:fedora:w3c-libwww-apps, p-cpe:/a:fedoraproject:fedora:w3c-libwww-debuginfo, p-cpe:/a:fedoraproject:fedora:w3c-libwww-devel, cpe:/o:fedoraproject:fedora_core:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/10/07

Reference Information

CVE: CVE-2005-3183

FEDORA: 2005-952

CWE: 20