CVE-2005-3183

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The HTBoundary_put_block function in HTBound.c for W3C libwww (w3c-libwww) allows remote servers to cause a denial of service (segmentation fault) via a crafted multipart/byteranges MIME message that triggers an out-of-bounds read.

References

ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2006.10/SCOSA-2006.10.txt

http://secunia.com/advisories/17119

http://secunia.com/advisories/17122

http://secunia.com/advisories/17489

http://secunia.com/advisories/17814

http://secunia.com/advisories/19193

http://secunia.com/advisories/25098

http://www.mandriva.com/security/advisories?name=MDKSA-2005:210

http://www.redhat.com/support/errata/RHSA-2007-0208.html

http://www.securityfocus.com/advisories/9444

http://www.securityfocus.com/advisories/9445

http://www.securityfocus.com/bid/15035

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=159597

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9653

https://usn.ubuntu.com/220-1/

Details

Source: MITRE

Published: 2005-10-12

Updated: 2018-10-03

Type: CWE-20

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:w3c:libwww:*:*:*:*:*:*:*:*

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
95408FreeBSD : libwww -- multiple vulnerabilities (18449f92-ab39-11e6-8011-005056925db4)NessusFreeBSD Local Security Checks
medium
67474Oracle Linux 4 : w3c-libwww (ELSA-2007-0208)NessusOracle Linux Local Security Checks
medium
67040CentOS 4 : w3c-libwww (CESA-2007:0208)NessusCentOS Local Security Checks
medium
60173Scientific Linux Security Update : w3c-libwww on SL4 i386/x86_64NessusScientific Linux Local Security Checks
medium
25136RHEL 4 : w3c-libwww (RHSA-2007:0208)NessusRed Hat Local Security Checks
medium
20762Ubuntu 4.10 / 5.04 / 5.10 : w3c-libwww vulnerability (USN-220-1)NessusUbuntu Local Security Checks
medium
20443Mandrake Linux Security Advisory : w3c-libwww (MDKSA-2005:210)NessusMandriva Local Security Checks
medium
19972Fedora Core 3 : w3c-libwww-5.4.0-10.0.FC3.1 (2005-953)NessusFedora Local Security Checks
medium
19971Fedora Core 4 : w3c-libwww-5.4.0-13.0.FC4.1 (2005-952)NessusFedora Local Security Checks
medium