SUSE-SA:2005:057: opera

High Nessus Plugin ID 19936


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2005:057 (opera).

This update upgrades the Opera web browser to the 8.50 release.

Besides the changes in 8.50 that are listed in following security problems were fixed:

1. Attached files are opened without any warnings directly from the user's cache directory. This can be exploited to execute arbitrary Javascript in context of 'file://'.

2. Normally, filename extensions are determined by the 'Content-Type' in Opera Mail. However, by appending an additional '.' to the end of a filename, an HTML file could be spoofed to be e.g. 'image.jpg.'.

These two vulnerabilities combined may be exploited to conduct script insertion attacks if the user chooses to view an attachment named e.g. 'image.jpg.' e.g. resulting in disclosure of local files.


Plugin Details

Severity: High

ID: 19936

File Name: suse_SA_2005_057.nasl

Version: $Revision: 1.4 $

Agent: unix

Published: 2005/10/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list