SUSE SLES12 Security Update : postgresql14 (SUSE-SU-2024:1703-1)

low Nessus Plugin ID 197549

Language:

Synopsis

The remote SUSE host is missing a security update.

Description

The remote SUSE Linux SLES12 / SLES_SAP12 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2024:1703-1 advisory.

- Missing authorization in PostgreSQL built-in views pg_stats_ext and pg_stats_ext_exprs allows an unprivileged database user to read most common values and other statistics from CREATE STATISTICS commands of other users. The most common values may reveal column values the eavesdropper could not otherwise read or results of functions they cannot execute. Installing an unaffected version only fixes fresh PostgreSQL installations, namely those that are created with the initdb utility after installing that version.
Current PostgreSQL installations will remain vulnerable until they follow the instructions in the release notes. Within major versions 14-16, minor versions before PostgreSQL 16.3, 15.7, and 14.12 are affected.
Versions before PostgreSQL 14 are unaffected. (CVE-2024-4317)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://bugzilla.suse.com/1224038

https://bugzilla.suse.com/1224051

http://www.nessus.org/u?1fbea3f3

https://www.suse.com/security/cve/CVE-2024-4317

Plugin Details

Severity: Low

ID: 197549

File Name: suse_SU-2024-1703-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 5/21/2024

Updated: 5/24/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2024-4317

CVSS v3

Risk Factor: Low

Base Score: 3.1

Temporal Score: 2.7

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:novell:suse_linux:12, p-cpe:/a:novell:suse_linux:postgresql14-pltcl, p-cpe:/a:novell:suse_linux:postgresql14-server, p-cpe:/a:novell:suse_linux:postgresql14-plperl, p-cpe:/a:novell:suse_linux:postgresql14-docs, p-cpe:/a:novell:suse_linux:postgresql14, p-cpe:/a:novell:suse_linux:postgresql14-contrib, p-cpe:/a:novell:suse_linux:postgresql14-server-devel, p-cpe:/a:novell:suse_linux:postgresql14-devel, p-cpe:/a:novell:suse_linux:postgresql14-plpython

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/20/2024

Vulnerability Publication Date: 5/9/2024

Reference Information

CVE: CVE-2024-4317

IAVB: 2024-B-0062

SuSE: SUSE-SU-2024:1703-1