Firefox < 1.0.7 Multiple Vulnerabilities

High Nessus Plugin ID 19719


A web browser on the remote host is prone to multiple flaws, including arbitrary code execution.


The remote host is using Firefox, an alternative web browser.

The installed version of Firefox contains various security issues, several of which are critical as they can be easily exploited to execute arbitrary shell code on the remote host.


Upgrade to Firefox 1.0.7 or later.

See Also

Plugin Details

Severity: High

ID: 19719

File Name: mozilla_firefox_106.nasl

Version: $Revision: 1.29 $

Type: local

Agent: windows

Family: Windows

Published: 2005/09/17

Modified: 2017/06/06

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/09/09

Vulnerability Publication Date: 2005/08/09

Reference Information

CVE: CVE-2005-2602, CVE-2005-2701, CVE-2005-2702, CVE-2005-2703, CVE-2005-2704, CVE-2005-2705, CVE-2005-2706, CVE-2005-2707, CVE-2005-2871, CVE-2005-3089

BID: 14526, 14784, 14916, 14917, 14918, 14919, 14920, 14921, 14923, 14924

OSVDB: 18691, 19255, 19615, 19643, 19644, 19645, 19646, 19647, 19648, 19649, 59850

CWE: 94