FreeBSD : dnrd -- remote buffer and stack overflow vulnerabilities (e72fd82b-fa01-11d9-bc08-0001020eed82)

High Nessus Plugin ID 19358


The remote FreeBSD host is missing a security-related update.


Natanael Copa reports that dnrd is vulnerable to a remote buffer overflow and a remote stack overflow. These vulnerabilities can be triggered by sending invalid DNS packets to dnrd.

The buffer overflow could potentially be used to execute arbitrary code with the permissions of the dnrd daemon. Note that dnrd runs in an chroot environment and runs as non-root.

The stack overflow vulnerability can cause dnrd to crash.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 19358

File Name: freebsd_pkg_e72fd82bfa0111d9bc080001020eed82.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/08/01

Modified: 2014/09/18

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:dnrd, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/07/21

Vulnerability Publication Date: 2005/07/21

Reference Information

CVE: CVE-2005-2315, CVE-2005-2316