FreeBSD : phppgadmin -- 'formLanguage' local file inclusion vulnerability (88188a8c-eff6-11d9-8310-0001020eed82)

Medium Nessus Plugin ID 19350


The remote FreeBSD host is missing a security-related update.


A Secunia Advisory reports :

A vulnerability has been reported in phpPgAdmin, which can be exploited by malicious people to disclose sensitive information.

Input passed to the 'formLanguage' parameter in 'index.php' isn't properly verified, before it is used to include files. This can be exploited to include arbitrary files from local resources.

Successful exploitation requires that 'magic_quotes_gpc' is disabled.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 19350

File Name: freebsd_pkg_88188a8ceff611d983100001020eed82.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/08/01

Modified: 2016/05/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:U/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:phppgadmin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2005/07/08

Vulnerability Publication Date: 2005/07/05

Reference Information

CVE: CVE-2005-2256

BID: 14142

Secunia: 15941