FreeBSD : fetchmail -- remote root/code injection from malicious POP3 server (3497d7be-2fef-45f4-8162-9063751b573a)

Medium Nessus Plugin ID 19339

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

fetchmail's POP3/UIDL code does not truncate received UIDs properly. A malicious or compromised POP3 server can thus corrupt fetchmail's stack and inject code when fetchmail is using UIDL, either through configuration, or as a result of certain server capabilities. Note that fetchmail is run as root on some sites, so an attack might compromise the root account and thus the whole machine.

Solution

Update the affected package.

See Also

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=83805

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=212762

http://www.fetchmail.info/fetchmail-SA-2005-01.txt

http://www.nessus.org/u?30158de5

Plugin Details

Severity: Medium

ID: 19339

File Name: freebsd_pkg_3497d7be2fef45f481629063751b573a.nasl

Version: 1.18

Type: local

Published: 2005/08/01

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:fetchmail, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/07/20

Vulnerability Publication Date: 2005/07/20

Reference Information

CVE: CVE-2005-2335