Slackware Linux 15.0 / current util-linux Vulnerability (SSA:2024-088-02)

high Nessus Plugin ID 192679


The remote Slackware Linux host is missing a security update to util-linux.


The version of util-linux installed on the remote host is prior to 2.37.4 / 2.40. It is, therefore, affected by a vulnerability as referenced in the SSA:2024-088-02 advisory.

- wall in util-linux through 2.40, often installed with setgid tty permissions, allows escape sequences to be sent to other users' terminals through argv. (Specifically, escape sequences received from stdin are blocked, but escape sequences received from argv are not blocked.) There may be plausible scenarios where this leads to account takeover. (CVE-2024-28085)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected util-linux package.

See Also

Plugin Details

Severity: High

ID: 192679

File Name: Slackware_SSA_2024-088-02.nasl

Version: 1.0

Type: local

Published: 3/29/2024

Updated: 3/29/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: High

Score: 7.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2024-28085


Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:slackware:slackware_linux:15.0, p-cpe:/a:slackware:slackware_linux:util-linux, cpe:/o:slackware:slackware_linux

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/28/2024

Vulnerability Publication Date: 3/27/2024

Reference Information

CVE: CVE-2024-28085