SUSE-SA:2005:040: heimdal

High Nessus Plugin ID 19249


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2005:040 (heimdal).

A remote buffer overflow has been fixed in the heimdal / kerberos telnetd daemon which could lead to a remote user executing code as root by overflowing a buffer.

This attack requires the use of the kerberized telnetd of the heimdal suite, which is not used by default on SUSE systems.

This is tracked by the Mitre CVE ID CVE-2005-2040.


Plugin Details

Severity: High

ID: 19249

File Name: suse_SA_2005_040.nasl

Version: $Revision: 1.5 $

Agent: unix

Published: 2005/07/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list