SUSE-SA:2005:032: java2

High Nessus Plugin ID 19241


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2005:032 (java2).

Two security bugs in the SUN Java implementation have been fixed.

Java Web Start can be exploited remotely due to an error in input validation of tags in JNLP files, so an attacker can pass arbitrary command-line options to the virtual machine to disable the sandbox and get access to files.

This is tracked by the Mitre CVE ID CVE-2005-0836.

The second bug is equal to the first one but can also triggered by untrusted applets.

This is tracked by the Mitre CVE ID CVE-2005-1974.


Plugin Details

Severity: High

ID: 19241

File Name: suse_SA_2005_032.nasl

Version: $Revision: 1.7 $

Agent: unix

Published: 2005/07/20

Modified: 2011/11/03

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list