AlmaLinux 9 : postgresql-jdbc (ALSA-2024:1436)

critical Nessus Plugin ID 192394

Synopsis

The remote AlmaLinux host is missing a security update.

Description

The remote AlmaLinux 9 host has a package installed that is affected by a vulnerability as referenced in the ALSA-2024:1436 advisory.

- pgjdbc, the PostgreSQL JDBC Driver, allows attacker to inject SQL if using PreferQueryMode=SIMPLE. Note this is not the default. In the default mode there is no vulnerability. A placeholder for a numeric value must be immediately preceded by a minus. There must be a second placeholder for a string value after the first placeholder; both must be on the same line. By constructing a matching string payload, the attacker can inject SQL to alter the query,bypassing the protections that parameterized queries bring against SQL Injection attacks. Versions before 42.7.2, 42.6.1, 42.5.5, 42.4.4, 42.3.9, and 42.2.8 are affected.
(CVE-2024-1597)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected postgresql-jdbc package.

See Also

https://errata.almalinux.org/9/ALSA-2024-1436.html

Plugin Details

Severity: Critical

ID: 192394

File Name: alma_linux_ALSA-2024-1436.nasl

Version: 1.1

Type: local

Published: 3/21/2024

Updated: 3/26/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2024-1597

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:alma:linux:postgresql-jdbc, cpe:/o:alma:linux:9, cpe:/o:alma:linux:9::appstream, cpe:/o:alma:linux:9::baseos, cpe:/o:alma:linux:9::crb, cpe:/o:alma:linux:9::highavailability, cpe:/o:alma:linux:9::nfv, cpe:/o:alma:linux:9::realtime, cpe:/o:alma:linux:9::resilientstorage, cpe:/o:alma:linux:9::sap, cpe:/o:alma:linux:9::sap_hana, cpe:/o:alma:linux:9::supplementary

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 3/20/2024

Vulnerability Publication Date: 2/15/2024

Reference Information

CVE: CVE-2024-1597

CWE: 89