FreeBSD : awstats -- arbitrary command execution (fdad8a87-7f94-11d9-a9e7-0001020eed82)

High Nessus Plugin ID 19185


The remote FreeBSD host is missing a security-related update.


Several input validation errors exist in AWStats that allow a remote unauthenticated attacker to execute arbitrary commands with the priviliges of the web server. These programming errors involve CGI parameters including loadplugin, logfile, pluginmode, update, and possibly others.

Additionally, the debug and other CGI parameters may be used to cause AWStats to disclose AWStats and system configuration information.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 19185

File Name: freebsd_pkg_fdad8a877f9411d9a9e70001020eed82.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2005/07/13

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:awstats, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2005/02/16

Vulnerability Publication Date: 2005/02/10

Reference Information

CVE: CVE-2005-0362, CVE-2005-0363, CVE-2005-0435, CVE-2005-0436, CVE-2005-0437, CVE-2005-0438

BID: 12543, 12545