Slackware Linux 15.0 / current ghostscript Vulnerability (SSA:2024-067-01)

high Nessus Plugin ID 191721


The remote Slackware Linux host is missing a security update to ghostscript.


The version of ghostscript installed on the remote host is prior to 10.03.0 / 9.55.0. It is, therefore, affected by a vulnerability as referenced in the SSA:2024-067-01 advisory.

- Artifex Ghostscript through 10.01.2 mishandles permission validation for pipe devices (with the %pipe% prefix or the | pipe character prefix). (CVE-2023-36664)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected ghostscript package.

See Also

Plugin Details

Severity: High

ID: 191721

File Name: Slackware_SSA_2024-067-01.nasl

Version: 1.0

Type: local

Published: 3/7/2024

Updated: 3/7/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-36664


Risk Factor: High

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:ghostscript, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/7/2024

Vulnerability Publication Date: 6/25/2023

Reference Information

CVE: CVE-2023-36664

IAVB: 2023-B-0041-S