FreeBSD : xpdf -- buffer overflow vulnerability (e3e266e9-5473-11d9-a9e7-0001020eed82)

High Nessus Plugin ID 19147


The remote FreeBSD host is missing one or more security-related updates.


An iDEFENSE Security Advisory reports :

Remote exploitation of a buffer overflow vulnerability in the xpdf PDF viewer, as included in multiple Linux distributions, could allow attackers to execute arbitrary code as the user viewing a PDF file.
The offending code can be found in the Gfx::doImage() function in the source file xpdf/


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 19147

File Name: freebsd_pkg_e3e266e9547311d9a9e70001020eed82.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2005/07/13

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:cups-base, p-cpe:/a:freebsd:freebsd:gpdf, p-cpe:/a:freebsd:freebsd:kdegraphics, p-cpe:/a:freebsd:freebsd:koffice, p-cpe:/a:freebsd:freebsd:pdftohtml, p-cpe:/a:freebsd:freebsd:teTeX-base, p-cpe:/a:freebsd:freebsd:xpdf, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/12/23

Vulnerability Publication Date: 2004/11/23

Reference Information

CVE: CVE-2004-1125

CWE: 20