FreeBSD : phpbb -- arbitrary command execution and other vulnerabilities (e3cf89f0-53da-11d9-92b7-ceadd4ac2edd)

High Nessus Plugin ID 19146


The remote FreeBSD host is missing a security-related update.


The ChangeLog for phpBB 2.0.11 states :

Changes since 2.0.10

- Fixed vulnerability in highlighting code (very high severity, please update your installation as soon as possible)

- Fixed unsetting global vars - Matt Kavanagh

- Fixed XSS vulnerability in username handling - AnthraX101

- Fixed not confirmed sql injection in username handling - warmth

- Added check for empty topic id in topic_review function

- Added visual confirmation mod to code base

Additionally, a US-CERT Technical Cyber Security Alert reports :

phpBB contains an user input validation problem with regard to the parsing of the URL. An intruder can deface a phpBB website, execute arbitrary commands, or gain administrative privileges on a compromised bulletin board.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 19146

File Name: freebsd_pkg_e3cf89f053da11d992b7ceadd4ac2edd.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2005/07/13

Modified: 2014/09/18

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:phpbb, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/12/22

Vulnerability Publication Date: 2004/11/18

Exploitable With

Metasploit (phpBB viewtopic.php Arbitrary Code Execution)

Reference Information

CVE: CVE-2004-1315

CERT: 497400