AlmaLinux 9 : opensc (ALSA-2024:0966)

medium Nessus Plugin ID 191113

Synopsis

The remote AlmaLinux host is missing a security update.

Description

The remote AlmaLinux 9 host has a package installed that is affected by a vulnerability as referenced in the ALSA-2024:0966 advisory.

- A vulnerability was found in OpenSC where PKCS#1 encryption padding removal is not implemented as side- channel resistant. This issue may result in the potential leak of private data. (CVE-2023-5992)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected opensc package.

See Also

https://errata.almalinux.org/9/ALSA-2024-0966.html

Plugin Details

Severity: Medium

ID: 191113

File Name: alma_linux_ALSA-2024-0966.nasl

Version: 1.0

Type: local

Published: 2/28/2024

Updated: 2/28/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2023-5992

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:alma:linux:opensc, cpe:/o:alma:linux:9, cpe:/o:alma:linux:9::appstream, cpe:/o:alma:linux:9::baseos, cpe:/o:alma:linux:9::crb, cpe:/o:alma:linux:9::highavailability, cpe:/o:alma:linux:9::nfv, cpe:/o:alma:linux:9::realtime, cpe:/o:alma:linux:9::resilientstorage, cpe:/o:alma:linux:9::sap, cpe:/o:alma:linux:9::sap_hana, cpe:/o:alma:linux:9::supplementary

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2/26/2024

Vulnerability Publication Date: 1/31/2024

Reference Information

CVE: CVE-2023-5992

CWE: 203