FreeBSD : lighttpd -- script source disclosure vulnerability (bdad9ada-8a52-11d9-9e53-000a95bc6fae)

Medium Nessus Plugin ID 19104


The remote FreeBSD host is missing a security-related update.


The lighttpd website reports :

In lighttpd 1.3.7 and below it is possible to fetch the source files which should be handled by CGI or FastCGI applications.

The vulnerability is in the handling of urlencoded trailing NUL bytes.
Installations that do not use CGI or FastCGI are not affected.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 19104

File Name: freebsd_pkg_bdad9ada8a5211d99e53000a95bc6fae.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/07/13

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:lighttpd, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2005/03/01

Vulnerability Publication Date: 2005/02/12

Reference Information

CVE: CVE-2005-0453

BID: 12567