FreeBSD : mplayer & libxine -- MMS and Real RTSP buffer overflow vulnerabilities (91c606fc-b5d0-11d9-a788-0001020eed82)

High Nessus Plugin ID 19031


The remote FreeBSD host is missing one or more security-related updates.


A xine security announcement reports :

By a user receiving data from a malicious network streaming server, an attacker can overrun a heap buffer, which can, on some systems, lead to or help in executing attacker-chosen malicious code with the permissions of the user running a xine-lib based media application.

Both the MMS and Real RTSP streaming client code made some too-strong assumptions on the transferred data. Several critical bounds checks were missing, resulting in the possibility of heap overflows, should the remote server not adhere to these assumptions. In the MMS case, a remote server could present content with too many individual streams;
in the RTSP case, a remote server's reply could have too many lines.

An attacker can set up a server delivering malicious data to the users. This can be used to overflow a heap buffer, which can, with certain implementations of heap management, lead to attacker chosen data written to the stack. This can cause attacker-chosen code being executed with the permissions of the user running the application. By tricking users to retrieve a stream, which can be as easy as providing a link on a website, this vulnerability can be exploited remotely.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 19031

File Name: freebsd_pkg_91c606fcb5d011d9a7880001020eed82.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2005/07/13

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libxine, p-cpe:/a:freebsd:freebsd:mplayer, p-cpe:/a:freebsd:freebsd:mplayer-esound, p-cpe:/a:freebsd:freebsd:mplayer-gtk, p-cpe:/a:freebsd:freebsd:mplayer-gtk-esound, p-cpe:/a:freebsd:freebsd:mplayer-gtk2, p-cpe:/a:freebsd:freebsd:mplayer-gtk2-esound, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/04/25

Vulnerability Publication Date: 2005/04/16

Reference Information

CVE: CVE-2005-1195

BID: 13270, 13271