FreeBSD : tiff -- tiffdump integer overflow vulnerability (8f86d8b5-6025-11d9-a9e7-0001020eed82)

Medium Nessus Plugin ID 19028


The remote FreeBSD host is missing one or more security-related updates.


Dmitry V. Levin found a potential integer overflow in the tiffdump utility which could lead to execution of arbitrary code. This could be exploited by tricking an user into executing tiffdump on a specially crafted tiff image.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 19028

File Name: freebsd_pkg_8f86d8b5602511d9a9e70001020eed82.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/07/13

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-tiff, p-cpe:/a:freebsd:freebsd:tiff, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/01/06

Vulnerability Publication Date: 2005/01/06

Reference Information

CVE: CVE-2004-1183