Slackware Linux 15.0 / current expat Multiple Vulnerabilities (SSA:2024-038-01)

high Nessus Plugin ID 190106


The remote Slackware Linux host is missing a security update to expat.


The version of expat installed on the remote host is prior to 2.6.0. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2024-038-01 advisory.

- libexpat through 2.5.0 allows a denial of service (resource consumption) because many full reparsings are required in the case of a large token for which multiple buffer fills are needed. (CVE-2023-52425)

- libexpat through 2.5.0 allows recursive XML Entity Expansion if XML_DTD is undefined at compile time.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade the affected expat package.

See Also

Plugin Details

Severity: High

ID: 190106

File Name: Slackware_SSA_2024-038-01.nasl

Version: 1.3

Type: local

Published: 2/7/2024

Updated: 4/5/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-52425


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:expat, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/7/2024

Vulnerability Publication Date: 2/4/2024

Reference Information

CVE: CVE-2023-52425, CVE-2023-52426

IAVA: 2024-A-0134-S