FreeBSD : postgresql -- multiple buffer overflows in PL/PgSQL parser (6b4b0b3f-8127-11d9-a9e7-0001020eed82)

Medium Nessus Plugin ID 18973


The remote FreeBSD host is missing one or more security-related updates.


The PL/PgSQL parser in postgresql is vulnerable to several buffer overflows. These could be exploited by a remote attacker to execute arbitrary code with the permissions of the postgresql server by running a specially crafted query.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 18973

File Name: freebsd_pkg_6b4b0b3f812711d9a9e70001020eed82.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/07/13

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ja-postgresql, p-cpe:/a:freebsd:freebsd:postgresql, p-cpe:/a:freebsd:freebsd:postgresql-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/02/17

Vulnerability Publication Date: 2005/02/07

Reference Information

CVE: CVE-2005-0247

CWE: 119