FreeBSD : pcal -- buffer overflow vulnerabilities (58fc2752-5f74-11d9-a9e7-0001020eed82)

Critical Nessus Plugin ID 18941


The remote FreeBSD host is missing a security-related update.


Danny Lungstrom has found two buffer overflow vulnerabilities in pcal which can lead to execution of arbitrary code by making a user run pcal on a specially crafted calendar file.


Update the affected package.

See Also

Plugin Details

Severity: Critical

ID: 18941

File Name: freebsd_pkg_58fc27525f7411d9a9e70001020eed82.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2005/07/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:pcal, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/01/06

Vulnerability Publication Date: 2004/12/15

Reference Information

CVE: CVE-2004-1289

BID: 12035, 12036