FreeBSD : php -- vulnerability in RFC 1867 file upload processing (562a3fdf-16d6-11d9-bc4a-000c41e2cdad)

High Nessus Plugin ID 18937


The remote FreeBSD host is missing one or more security-related updates.


Stefano Di Paola discovered an issue with PHP that could allow someone to upload a file to any directory writeable by the httpd process. Any sanitizing performed on the prepended directory path is ignored. This bug can only be triggered if the $_FILES element name contains an underscore.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 18937

File Name: freebsd_pkg_562a3fdf16d611d9bc4a000c41e2cdad.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/07/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:mod_php4, p-cpe:/a:freebsd:freebsd:mod_php5, p-cpe:/a:freebsd:freebsd:php4, p-cpe:/a:freebsd:freebsd:php4-cgi, p-cpe:/a:freebsd:freebsd:php5, p-cpe:/a:freebsd:freebsd:php5-cgi, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/09/15

Vulnerability Publication Date: 2004/09/15