FreeBSD : cups-base -- HPGL buffer overflow vulnerability (40a3bca2-6809-11d9-a9e7-0001020eed82)

Medium Nessus Plugin ID 18916


The remote FreeBSD host is missing one or more security-related updates.


Ariel Berkman has discovered a buffer overflow vulnerability in CUPS's HPGL input driver. This vulnerability could be exploited to execute arbitrary code with the permission of the CUPS server by printing a specially crated HPGL file.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 18916

File Name: freebsd_pkg_40a3bca2680911d9a9e70001020eed82.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/07/13

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:cups-base, p-cpe:/a:freebsd:freebsd:fr-cups-base, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/01/17

Vulnerability Publication Date: 2004/12/15

Reference Information

CVE: CVE-2004-1267

BID: 11968

CWE: 119