FreeBSD : kdelibs -- insecure temporary file creation (29dd0065-81fa-11d9-a9e7-0001020eed82)

Low Nessus Plugin ID 18881


The remote FreeBSD host is missing one or more security-related updates.


Davide Madrisan reports :

The `dcopidlng' script in the KDE library package (kdelibs-3.3.2/dcop/dcopidlng/dcopidlng) creates temporary files in a unsecure manner.

Note: dcopidlng is only used at build time, so only users installing KDE are vulnerable, not users already running KDE.


Update the affected packages.

See Also

Plugin Details

Severity: Low

ID: 18881

File Name: freebsd_pkg_29dd006581fa11d9a9e70001020eed82.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/07/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ja-kdelibs, p-cpe:/a:freebsd:freebsd:kdelibs, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/02/18

Vulnerability Publication Date: 2005/01/21

Reference Information

CVE: CVE-2005-0365