FreeBSD : racoon -- improper certificate handling (2328adef-157c-11d9-8402-000d93664d5c)

High Nessus Plugin ID 18869


The remote FreeBSD host is missing a security-related update.


Thomas Walpuski noted when OpenSSL would detect an error condition for a peer certificate, racoon mistakenly ignored the error. This could allow five invalid certificate states to properly be used for authentication.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 18869

File Name: freebsd_pkg_2328adef157c11d98402000d93664d5c.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2005/07/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:racoon, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/10/03

Vulnerability Publication Date: 2004/01/31