FreeBSD : Apache 1.3 IP address access control failure on some 64-bit platforms (09d418db-70fd-11d8-873f-0020ed76ef5a)

High Nessus Plugin ID 18833


The remote FreeBSD host is missing one or more security-related updates.


Henning Brauer discovered a programming error in Apache 1.3's mod_access that results in the netmasks in IP address access control rules being interpreted incorrectly on 64-bit, big-endian platforms.
In some cases, this could cause a `deny from' IP address access control rule including a netmask to fail.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 18833

File Name: freebsd_pkg_09d418db70fd11d8873f0020ed76ef5a.nasl

Version: $Revision: 1.20 $

Type: local

Published: 2005/07/13

Modified: 2013/10/30

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:apache, p-cpe:/a:freebsd:freebsd:apache+mod_ssl, p-cpe:/a:freebsd:freebsd:apache+ssl, p-cpe:/a:freebsd:freebsd:ru-apache, p-cpe:/a:freebsd:freebsd:ru-apache+mod_ssl, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2004/03/08

Vulnerability Publication Date: 2004/03/07

Reference Information

CVE: CVE-2003-0993

BID: 9829