FreeBSD : realplayer -- arbitrary file deletion and other vulnerabilities (02274fd9-6bc5-11d9-8edb-000a95bc6fae)

High Nessus Plugin ID 18818


The remote FreeBSD host is missing a security-related update.


An NGSSoftware Insight Security Research Advisory reports :

Two vulnerabilities have been discovered in RealPlayer which may potentially be leveraged to allow remote code execution, or may used in combination with the Real Metadata Package File Deletion vulnerability to reliably delete files from a users system.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 18818

File Name: freebsd_pkg_02274fd96bc511d98edb000a95bc6fae.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/07/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-realplayer, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2005/01/21

Vulnerability Publication Date: 2004/10/06