Slackware 10.0 / 10.1 / 8.1 / 9.0 / 9.1 / current : java (jre, j2sdk) (SSA:2005-170-01)

High Nessus Plugin ID 18802


The remote Slackware host is missing a security update.


Sun has released a couple of security advisories pertaining to both the Java Runtime Environment and the Standard Edition Development Kit.
These could allow applets to read or write to local files. For more details, Sun's advisories may be found here: Slackware repackage's Sun's Java(TM) binaries without changing them, so the packages from Slackware -current should be used for all glibc based Slackware versions.


Update the affected j2sdk and / or jre packages.

See Also

Plugin Details

Severity: High

ID: 18802

File Name: Slackware_SSA_2005-170-01.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2005/07/13

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:j2sdk, p-cpe:/a:slackware:slackware_linux:jre, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.0, cpe:/o:slackware:slackware_linux:10.1, cpe:/o:slackware:slackware_linux:8.1, cpe:/o:slackware:slackware_linux:9.0, cpe:/o:slackware:slackware_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Patch Publication Date: 2005/06/20

Vulnerability Publication Date: 2005/06/13

Reference Information

OSVDB: 17299, 17340

SSA: 2005-170-01