Slackware 10.0 / 9.0 / 9.1 / current : Qt (SSA:2004-236-01)

High Nessus Plugin ID 18767


The remote Slackware host is missing a security update.


New Qt packages are available for Slackware 9.0, 9.1, 10.0, and
-current to fix security issues. Bugs in the routines that handle PNG, BMP, GIF, and JPEG images may allow an attacker to cause unauthorized code to execute when a specially crafted image file is processed.
These flaws may also cause crashes that lead to a denial of service.


Update the affected qt package.

See Also

Plugin Details

Severity: High

ID: 18767

File Name: Slackware_SSA_2004-236-01.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/07/13

Modified: 2016/05/20

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:qt, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.0, cpe:/o:slackware:slackware_linux:9.0, cpe:/o:slackware:slackware_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/08/23

Vulnerability Publication Date: 2004/08/18

Reference Information

CVE: CVE-2004-0691, CVE-2004-0692, CVE-2004-0693

OSVDB: 9026, 9035, 9036

SSA: 2004-236-01