Slackware 9.0 / 9.1 / current : INN security update (SSA:2004-014-02)

High Nessus Plugin ID 18755


The remote Slackware host is missing a security update.


INN (InterNetNews) is used to run a news (NNTP) server. New INN packages are available for Slackware 9.0, 9.1, and -current. These have been upgraded to inn-2.4.1 to fix a potentially exploitable buffer overflow. All sites running INN should upgrade.


Update the affected inn package.

See Also

Plugin Details

Severity: High

ID: 18755

File Name: Slackware_SSA_2004-014-02.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2005/07/13

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:inn, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:9.0, cpe:/o:slackware:slackware_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Patch Publication Date: 2004/01/15

Reference Information

CVE: CVE-2004-0045

SSA: 2004-014-02