Debian DSA-5570-1 : nghttp2 - security update

high Nessus Plugin ID 186518

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 11 / 12 host has packages installed that are affected by a vulnerability as referenced in the dsa-5570 advisory.

- The HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023. (CVE-2023-44487)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the nghttp2 packages.

For the stable distribution (bookworm), this problem has been fixed in version 1.52.0-1+deb12u1.

See Also

https://security-tracker.debian.org/tracker/source-package/nghttp2

https://www.debian.org/security/2023/dsa-5570

https://security-tracker.debian.org/tracker/CVE-2023-44487

https://packages.debian.org/source/bullseye/nghttp2

Plugin Details

Severity: High

ID: 186518

File Name: debian_DSA-5570.nasl

Version: 1.2

Type: local

Agent: unix

Published: 12/1/2023

Updated: 2/9/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-44487

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libnghttp2-14, p-cpe:/a:debian:debian_linux:libnghttp2-dev, p-cpe:/a:debian:debian_linux:libnghttp2-doc, p-cpe:/a:debian:debian_linux:nghttp2, p-cpe:/a:debian:debian_linux:nghttp2-client, p-cpe:/a:debian:debian_linux:nghttp2-proxy, p-cpe:/a:debian:debian_linux:nghttp2-server, cpe:/o:debian:debian_linux:11.0, cpe:/o:debian:debian_linux:12.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/1/2023

Vulnerability Publication Date: 10/10/2023

CISA Known Exploited Vulnerability Due Dates: 10/31/2023

Reference Information

CVE: CVE-2023-44487